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AASHTOWare Project Estimator 2.16b 

Procedures for Consultants 

The New York State Thruway Authority publishes on its public website an AASHTOWare 

Project Estimator catalog for projects called nystaenglishcatalog.cat.   The catalog is updated by 

the Thruway Authority, as needed.  The catalog contains various support data such as work items 

and project codes that are approved for use on current projects.  

Due to the great fluctuation in market prices over the past few years and the relatively small 

number of occurrences for most items (other than the typical Lump Sum or Each items), it has 

been decided not to include historical bid price statistics in future catalogs. 

Creating an Estimate 

1. Activate AASHTOWare Project Estimator program and log in. 

2. Select the ‘Catalog Tools command from the toolbar and scroll down to ‘Open a Catalog’.  

Select nystaenglishcatalog.cat and click ‘OK’.   

3. Select the ‘New’ command from the File menu.  Once the New Estimate dialog box opens, 

choose to open either a Blank Estimate or a Template (see Appendix A - Templates).  

4. Enter the ESTIMATE ID.  The ID for estimates submitted as part of the “Plans, 

Specification and Estimate” (PS&E) submission shall be the first six characters of the 

Thruway Authority Project Identification Number (PIN), without any periods (e.g. A72001). 

5. The SPEC YEAR should have been set automatically when the estimate was created. It is 

dependent upon which catalog was active during the creation process. The 

nystaenglishcatalog.cat should set the spec. year to 08. The 08 spec. year item catalog 

includes approved NYSDOT Standard Specification book items and NYSDOT special 

specification items also approved for use at NYSTA, as well as approved NYSTA special 

specification items. 

6. Enter the LETTING DATE.   

7. The UNIT SYSTEM should have been set automatically when the estimate was created.  It 

is dependent upon the catalog that was active when the estimate was created. The 

nystaenglishcatalog.cat should automatically set the Unit System to English. 

8. The LATITUDE OF MIDPOINT and LONGITUDE OF MIDPOINT shall be based upon 

predefined points for the primary county in which the project is located or predefined points 

for the Division or State if the project covers much larger areas (see Appendix B - Latitude & 

Longitude Values for Capital Projects). 

9. Enter the STATE PROJECT NUMBER (TA #).  This shall be the same TA number to be 

used in the Estimate Description. 

10. Enter the ESTIMATE DESCRIPTION. - The estimate description field shall begin with the 

TA number followed by the Short Description from the Thruway Authority’s Capital 
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Program Management System. The entire description should be limited to 60 characters (e.g. 

TABS 24-2B, Castleton Bridge Rehabilitation).  

11. Select the appropriate WORK TYPE from the drop-down list (see Appendix C -Estimator 

Code Values). 

12. Select the appropriate HIGHWAY TYPE from the drop-down list.  The code appropriate for 

most of the project should be selected.   

13. Select the appropriate URBAN/RURAL TYPE from the drop-down list.  The code 

appropriate for most of the project should be selected.   

14. Select the appropriate PRIME SEASON from the drop-down list. The code selected should 

reflect when construction on the contract will begin in full (i.e. more than just prep work such 

as clearing and grubbing). 

15. Select the appropriate COUNTY from the drop-down list.  The County selected should be 

the county in which most of the work will be performed.  Also included are codes for each 

Thruway Authority Division, which should be used if the project covers an entire Division 

(e.g. Albany Division Bridge Where and When contracts or Division Wide Pavement 

Striping Contracts). 

16. The DISTRICT shall be based upon the Thruway Division in which the project is located: 

▪ 21 – New York 

▪ 22 - Albany 

▪ 23 - Syracuse 

▪ 24 - Buffalo  

17. The CONTINGENCY % field can be used to automatically account for mobilization early 

in the project.  Simply enter 4% in that field and the project total will be increased four 

percent.  However, in the estimate submitted to the Thruway Authority as part of the “Plans, 

Specification and Estimate” (PS&E) submission the Contingency % field should be set to 

zero and a Mobilization item, with set dollar amounts, added to the appropriate group.  

18. Select the ‘Save’ command from the File menu.  The first time the project is saved, the 

program will use the ESTIMATE ID as the default file name. The program does save 

backups by default every 15 minutes. It also saves up to 4 previous versions of the estimate. 

19. Add a GROUP. At the Thruway Authority, Estimator Groups are equivalent to Fiscal or 

Engineering Shares. Contact the Thruway Project Manager to obtain information 

regarding how many groups to create and their descriptions. It is important not to leave 

the description field blank for any Group. Estimator automatically creates the first group. Use 

the ‘Add Group’ command on the Edit menu to add additional groups, as needed. Estimator 

displays a subtotal cost for each Group on the Group Header screens, as well as a total for the 

entire project on the Project Header screen. If a project will have multiple groups with many 

common items, it is quicker to create one group and use the ‘Copy’ and ’Paste” commands 

on that group to create the other groups.  The copies will have all the items, quantities and 

prices from the original group (however with unique line numbers). Users can then remove 

or add items as appropriate, as well as edit quantities.  
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20. Add an item to a group. Either use the ‘Add item’ command from the Edit menu or click a 

blank Item Number box in the Grid view to enter an item.  

When entering data in the Item Number box on the Add Item screen, the program will 

display the closest valid item number in the Estimator catalog.  Entering more characters will 

eventually cause the correct item to display.  If the item does not appear, then either there 

was something wrong with the entry or the item is not in the current catalog.  For example, 

entering a 502 causes the program to fill the rest of the field with the closest valid spec 

number, Entering an additional character 502.1 results in the display changing to 502.1001  

18.  Estimator is also configured to allow users to enter items not yet in the catalog.  

However, these items should be replaced by ones from the Estimator catalog once they have 

been added to the Estimator catalog by the Thruway Authority (See Appendix D - Verifying 

Estimate and Placeholder Items).  

21. While items are usually added in sequential order to display in ascending order in the tree 

view, additional items can always be added out of sequence at the end of the Group and 

subsequently re-sorted.  This is accomplished by selecting a Group in the Tree view and 

clicking on the Item Number header in the Grid view.  The first click will sort the items in 

ascending order, while a second click will sort them in descending order.  Once in ascending 

order, select the ‘Renumber Using Current Order’ command from the Edit menu to make the 

sort permanent and to update the display in the Tree view. 

22. Enter a Quantity and Unit Price for each item.  If the item has a Reference Price or historical 

Bid Price associated with that item in the Estimator catalog, then that price will be displayed 

by default.  The user may override the default price by simply entering one manually in the 

Unit Price field.  Consultants can use the Average Weighted Bid Price Book (AWBPB) the 

Thruway Authority has developed to help estimate an item’s cost. Besides general statistical 

data on each item, the AWBPB lists all the contracts the item has been used on (for the 

period of time covered by the book) and specific bid statistics for each contract.  

 

23. Once all the items have been entered, the user should verify the estimate by clicking the 

Yellow Check Mark on the Toolbar or selecting the ‘Verify Estimate’ command from the 

Edit menu. Estimator will check the estimate and identify errors. One of the key checks is for 

any items missing from the Estimator catalog or items that have been improperly entered. 

See Appendix D for more information. 

 

Verifying an estimate does not flag the following: 

▪ Lump sum quantities that do not equal 1. 

▪ Dollar and Cent Unit Item prices not equal to $1.00. 

▪ The same items in different groups and having differing unit prices. 

▪ Data in fields that are not used by New York State Thruway Authority. The following 

fields should not contain any data: 

• Item Level Supplemental Description 

• Group / Engineering Share level Alternate Code 

 

24. AASHTOWare Project Estimator can employ alternate items, which requires bidders to 

eventually choose between certain predefined contract items.  To identify items as being 
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alternatives to each other, the same prefix code must be entered into the ALT CODE field for 

each alternate along with a unique suffix number for each alternate (e.g. AA1, AA2, AA3, 

AA4 are all alternatives to each other).  Different sets of alternate items can be created by 

specifying different prefixes (e.g. AA2 and AA3 are alternatives to AA1, while AB2 is an 

alternative just to AB1).  

To create pairs or groups of alternate items, simply enter the exact same prefix and suffix in 

the ALT CODE field of each item that belongs to a particular pair or group (e.g. enter AA1 

into the ALT CODE field for each of the items that should be bid on together, if chosen, and 

AA2 in the ALT CODE field of each of the items in the alternate group).  Estimator will 

utilize the lowest priced alternative(s) when calculating the total Group and Estimate Totals. 

Printing 

Select the ‘Print’ or “Print Preview” command from the File menu or click the printer icon on the 

Toolbar.  An option box will appear asking the user to select what format to use and what info is 

to appear on the report.  

▪ The default report lists each group, and all the items in each group. The shortest version of 

this report is run by leaving all boxes unchecked.  The report will include line number, item 

number, quantity, pay units, unit price, and extended amount. The next level of detail is 

available by selecting the option to show item descriptions.  This essentially doubles the size 

of the report by including the item description along with the other previously listed details.  

Other variations can be printed by selecting the option to hide prices, show notes for 

Groups/Items and/or show price bases details. 

▪ Total item Quantities across Groups – This report lists the total quantity of an item across 

groups.   It is sorted by item number, and prints item number, total estimate quantity (sum of 

item quantities from all groups), units, total unit price and total extended amount.  Other 

variations can be printed by selecting the option to show item descriptions or hide prices. 

▪ Summary of Quantities by items and Groups - This report lists each item and each group 

where that item is used.  It is sorted by item number then group, and prints item number, 

group, quantity in each group, unit price in each group and extended amount in each group. 

Other variations can be printed by selecting the option to show item descriptions or hide 

prices.  

 

Final Estimate 

As part of the standard “Plans, Specification and Estimate” (PS&E) submission, the Consultant 

should email the Thruway Project Manager the Estimator file along with the following 

information: 

• The Project Identification Number (PIN) 

• The Project Description 

• A list of each Group and their cost (Group Total) 

• The total Estimate Cost generated by Estimator. 
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Appendix A - Templates 

A template contains a list of items commonly used on a particular type of project (i.e. Structures, 

Truck Parking Expansion, etc…).  It may also contain general quantity and pricing information 

to assist users in estimating their particular project.  A user can then remove any items not 

needed, as well as add any extra items not in the template. They can then add or edit the 

quantities and prices for each item, as appropriate. 

The AASHTOWare Project Estimator program allows any user to create a template using an 

existing Estimator file by simply selecting the ‘Save As’ command from the File menu and 

selecting the ‘Estimate Template (*.etm)’ as the type of file to save to.  Once created and stored 

in the Template directory, whenever a user selects the ‘New’ command from the File menu a 

dialog box will appear asking the user to select one of the available templates or create a 

standard blank estimate. 
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 Appendix B - Latitude & Longitude Values for Capital Projects 

On all capital projects use the predefined values listed below.  The coordinates input into 

AASHTOWare Project Estimator will be used in the future to analyze bid data and generate 

location-specific bid history prices and trends. 

 

County-wide Projects 

Albany Lat: 4238’00” Long: 07347’00” 

Cayuga Lat: 4302’50” Long: 07637’00” 

Chautauqua Lat: 4224’40” Long: 07925’40” 

Columbia Lat: 4224’20” Long: 07331’30” 

Dutchess Lat: 4132’00” Long: 07349’30” 

Erie Lat: 4249’40” Long: 07847’30” 

Genesee Lat: 4301’10” Long: 07811’10” 

Greene Lat: 4218’30” Long: 07352’20” 

Herkimer Lat: 4300’50” Long: 07458’20” 

Madison Lat: 4305’40” Long: 07549’10” 

Monroe Lat: 4302’30” Long: 07741’40” 

Montgomery Lat: 4255’10” Long: 07426’20” 

Oneida Lat: 4307’30” Long: 07524’30” 

Onondaga Lat: 4307’00” Long: 07614’20” 

Ontario Lat: 4258’40” Long: 07713’30” 

Orange Lat: 4123’00” Long: 07406’10” 

Putnam Lat: 4125’50” Long: 07337’50” 

Rensselaer Lat: 4229’10” Long: 07341’50” 

Rockland Lat: 4106’10” Long: 07404’30” 

Schenectady Lat: 4249’30” Long: 07400’50” 

Seneca Lat: 4258’00” Long: 07650’20” 

Ulster Lat: 4152’50” Long: 07403’30” 

Westchester – I-87 Lat: 4059’40” Long: 07351’10” 

                       I-287 Lat: 4101’50” Long: 07345’00” 

                       I-95 Lat: 4057’20” Long: 07344’30” 

Bronx Lat: 4052’50” Long: 07350’00” 

 

Division-wide Projects 

Albany Lat: 4234’00” Long: 07347’00” 

Buffalo Lat: 4255’00” Long: 07846’00” 

New York Lat: 4108’00” Long: 07410’00” 

Syracuse Lat: 4306’00” Long: 07600’00” 

 

Statewide Projects 

  Lat: 4310’00” Long: 07540’00” 

 

For projects with work being performed at multiple discrete locations, the Latitude and 

Longitude for the location with the highest cost work should be reported. 
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APPENDIX C - Estimator Code Values 

 

 

AMIS Miscellaneous Buildings 

AROF Roofing 

ASMB Section Maintenance Buildings 

ASPB State Police Buildings 

ASSH Salt Sheds 

AWWT Wastewater Treatment Plant 

BFEN Bridge Fencing 

BMIS Miscellaneous Bridge 

BPAI Bridge Painting 

BREH Major Bridge Rehabilitation 

BRPL Bridge Replacement 

BSRS Bridge SRSO 

BWAS Bridge Washing 

 

BWWC Bridge Where and When 

Contract 

HCUL Major Culverts 

HMIS Miscellaneous Highway 

HONR 1R Highway Resurfacing 

HPMK Pavement Markings 

HREC 3R Highway 

Rehab/Reconstruction 

HSAF Highway Safety Only 

HTWR 2R Highway Rehabilitation 

ITS Intelligent Transportation 

Systems 

 

Highway Type Codes 

ASPH Asphalt                                                                                                                                                    

COMB Combination Asphalt & Concrete       

CONC Concrete 

NONE No Highway 

 

Urban/Rural Codes 

R Rural U Urban 

 

Prime Season Codes 

FALL Fall (9/22 to 12/22) 

SPRI Spring (3/22 to 6/22) 

SUMM Summer (6/22 to 9/22) 

WINT Winter (12/22 to 3/22) 

 

County Codes 

C01 Albany 

C05 Cayuga 

C06 Chautauqua 

C10 Columbia 

C13 Dutchess 

C14 Erie 

C18 Genesee 

C19 Greene 

C21 Herkimer 

C25 Madison 

C26 Monroe 

C27 Montgomery 

C29 Niagara 

C30 Oneida 

C31 Onondaga 

C32 Ontario 

C33 Orange 

C34 Orleans 

C35 Oswego 

C37 Putnam 

C38 Rensselaer 

C39 Rockland 

C41 Saratoga 

C42 Schenectady 

C45 Seneca 

C51 Ulster 

C52 Warren 

C53 Washington 

C54 Wayne 

C55 Westchester 

C61 Bronx 

D21 New York Division 

D22 Albany Division 

D23 Syracuse Division 

D24 Buffalo Division 
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APPENDIX C - Estimator Code Values 

 

 

Unit Codes 

ACRE Acre 

BAG Bag 

BF Board Ft. 

CDAY Calendar Day 

CF Cubic Ft. 

CW Calendar Week 

CY Cubic Yard 

DAY Day 

DC Dollars and Cents 

EACH Each 

ELOC Each Location 

F Feet 

FQU Quality Unit 

GAL Gallon 

HOUR Hour 

INCH Inch 

INTM Intersection Month 

LB Pound 

LF Linear Ft. 

LS Lump Sum 

MGAL Thousand Gallons 

MNTH Month 

PCNT Percent 

PDD Pressure Distributor Day 

QU Quality Unit 

SF Square Ft. 

SY Square Yard 

TON Ton 
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Appendix D - Verifying an Estimate and Flagging Errors 

 
1. When a user adds a blank item to an estimate, it is automatically flagged in the Tree view.  If 

a user clicks on the Item Number field and either selects an item from the catalog dropdown 

or enters an item number that exists in the catalog, then the error flag is automatically 

removed.  If the user enters an item number that is not in the catalog, the error flag will 

remain. 

 

2. When a user adds an item to an estimate, the Quantity, Unit Price and Extension fields are by 

default set to zero.  If the user blanks out any of these fields, rather than entering values, the 

item will automatically be flagged in the Tree view.  

 

3. The Verify command not only reports specific information on the errors Estimator has 

currently flagged, but also re-scans the entire estimate, flagging and reporting items that are 

no longer in the catalog (i.e. recently disapproved), as well as removing the flags on items 

that were not in the previous catalog, but are now in the current catalog.  The latter are 

particularly important since those error flags do not update automatically when the estimate 

is opened but do so only when the Verify command is run again or as specified in next 

Section. 

 

Verifying an estimate does not flag the following: 

▪ Lump sum quantities that do not equal 1. 

▪ Dollar and Cent Unit Item prices not equal to $1.00. 

▪ The same items in different groups and having differing unit prices. 

▪ Data in fields that are not used by New York State Thruway Authority. The following 

fields should not contain any data: 

• Item Level Supplemental Description 

• Group / Engineering Share level Alternate Code 

 

   Working with Placeholder Items in an Estimate 

When an item does not exist in the official Thruway catalog, the user may enter a placeholder in 

Estimator in the Item Number field, along with temporary entries in the Description, and Units of 

Measure fields.  They may then enter estimated values in the Quantity and Unit Price fields.  

The placeholder number and description should be the user’s recommendations for the item they 

are proposing be added to the official Thruway catalog.  When replacing the placeholder, 

Estimator will interpret this action as selection of a completely new item number and update all 

the item information, as described in the first scenario below.  

Note that when the user clicks on the item selection list in the Item Number field, in order to 

replace the placeholder number, the list will automatically jump to the closest match. If the 

official item number is similar to that originally proposed, the user will only need to scroll back a 

few numbers to find the appropriate replacement item. This will be the case if the letter ‘a’ was 

used in the placeholder number as described above. 
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1. If a user clicks on a placeholder item’s Item Number field and selects an item from the 

catalog list that is different than the placeholder item number, it updates the Item Number, 

Description, and Units of Measure fields, leaving the Quantity, Unit Price and Extension 

fields untouched (assuming Unit Price was based on Ad-hoc pricing, otherwise changing the 

item number will zero out the Unit Price and Extension fields or apply that new items default 

price basis (i.e. Reference Price, Bid History, etc…).  The error flag is automatically 

removed. 

 

2. If a user clicks on a placeholder item’s Item Number field and selects an item from the 

catalog list that is exactly the same as the placeholder item number, Estimator does not 

update the Description or Units of Measure fields, even if those values in the catalog are 

different than what was originally entered in the estimate for the placeholder item.  It does 

leave the Quantity, Unit Price and Extension fields untouched.  However, the error flag is 

automatically removed, even though the item still contains incorrect information. 


